Shooters Forum banner

Oehler 35P chronograph not working.

730 Views 5 Replies 5 Participants Last post by  Kevinbear
Just picked up a Oehler 35P chronograph. Couldn't get it to work no matter what.

Using the 4 foot three reader setup. All the switches by the battery are off except #3. I tried plugging the readers in all configurations. The screen has the
"---0" as it it's ready to read but when I throw something through all 3 readers nothing happens. I even tried shooting a paintball gun through it and still nothing happens.

What could be wrong with it??
1 - 6 of 6 Posts
Read the manual for it, switches shouldn't be all off.

Welcome to the forum
Read the manual for it, switches shouldn't be all off.

Welcome to the forum

Read it. All of them except switch #3 are off. On the 4ft setting only switch #3 is supposed to be on.
Don't know the machine personally, but taking a guess. Thinking it might not be getting a "start" signal?
Could try plugging the mid-screen into the "start" port (if that is possible?), then running something over screens 2 and 3 to see if it reads something.
If so, that might indicate trouble with screen #1. Screen/ cable / connector.
Agree. Bad cable is a likely culprit and is not uncommon in cables with molded connectors like the 35P uses. To test the screens and cables, swap the screen plugs into different sockets. If two of the screens and cables are good and the third is bad, one combination of plug positions should result in a reading but with an error message to show the check screen number didn't match.

Another troubleshooting step is you could try turning switch 3 off and switch 2 on. That will cause a 2:1 reading error but will confirm you don't have a bad DIP switch in position 3 on the circuit board.

After that, it's time to call Oehler and get their advice. They may ask you to send them the sky screens or the unit, but they may also have other tests you can run.
  • Like
Reactions: 1
Did you check the battery voltage?

See less See more
1 - 6 of 6 Posts