Shooters Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I have a savage mark II special edition mako in .22lr and hav been having misfire problems. the firing pin leaves a mark on the casing but it doesnt always fire. This happns alot when using remington eley orange box. I really want to continue using this ammo because its so accurate. Does anyone know where i could get a new, hopefully improved firing pin, or somewhere i could send the bolt to get it fixed.
 

·
Banned
Joined
·
421 Posts
Is the gun nice and clean? New guns are usually coated in a cosmoline type rust preventative, and if not taken apart and cleaned real well, the action will be gummed up enough to cause light strikes like you are experiencing. Residue from firing can do the same thing. If you haven't taken the bolt out and cleaned it real well you might want to start there.
 

·
Super Moderator
Joined
·
13,630 Posts
As suggested, contact Savage customer support. (413) 568-7001. They can help you determine whether you have a gummed up bolt, headspace problem, or bad firing pin?
 

·
Registered
Joined
·
8 Posts
I had a little trouble like that with my 93R17 XP. Took the bolt apart and smoothed up all rough edges, but the spring for the firing pin was a little tight in the bolt, which I think was causing the light strikes. I couldn't hone that area, so I lightly smoothed the spring OD with fine sand paper. I almost never get a misfire or light strike now. It seems to be getting better, the more I shoot it.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #6 ·
Thanks. ill probably give cleaning the inside of the bolt a try.does anyone know how to take one apart,cause the instruction manual says not to take it apart. i checked the rim thickness of my ammo and the remington eley is .38-.39 compared to .42-.46 of the bargin ammo. could this be part of the problem??
 

·
Registered
Joined
·
1 Posts
Did you ever get your problem figured out. I'm having the same problem in my mk2 in 17 HM2 i've tried all the available loads for the gun all with the same problem. I ordered a new firing pin did not fix it. Tightened the bolt halves together as tight as i could get them seemed to help some.
 
1 - 9 of 9 Posts
Top